Support e-mail outage
Incident Report for Blue Box
Resolved
The issues with the support e-mail address have been resolved and e-mail is being processed normally.
Posted over 1 year ago. Jul 26, 2017 - 18:13 UTC
Investigating
We're experiencing issues processing email from our support email address. In the interim please reach us via Phone, Chat or logging into Support application directly
Posted over 1 year ago. Jul 26, 2017 - 17:47 UTC
This incident affected: App - Support System.